เลือกภาษา ไทย | อังกฤษ

ติดตั้งระบบ OBECLMS ระบบการจัดการเรียนการสอน Version3.2


ตรวจสอบระบบก่อนการติดตั้ง

ผ่านความต้องการของระบบ    ไม่ผ่านความต้องการของระบบ

โปรแกรมที่จำเป็นในการใช้งานระบบ OBECLMS

Apache Web Server เวอร์ชั่น 2.2.4 เวอร์ชั่น ของคุณ 2
PHP เวอร์ชั่น 4.3.0 หรือสูงกว่า (ไม่สูงกว่า 5.2.x) เวอร์ชั่น ของคุณ 5.3.29
MySQL Database เวอร์ชั่น 4.1.16 หรือมากกว่า เวอร์ชั่น ของคุณ mysqlnd 5.0.8-dev - 20102224 - $Id: 731e5b87ba42146a687c29995d2dfd8b4e40b325 $
Mail Sever ใช้ในการแจ้งเตือนการสมัครสมาชิกทาง E-mail ของผู้สอน (ไม่จำเป็น)


php configuration ที่จำเป็น (php.ini)

session.auto_start เซ็ตค่าให้เป็น 0
magic_quote_runtime เซ็ตค่าให้เป็น Off
safe_mode ต้องเป็น Off
file_uploads ต้องเป็น On
max_execution_time เซ็ตค่าขึ้นต่ำที่ 30 หรือ สูงกว่า (แนะนำให้สูงกว่า)
memory_limit เซ็ตค่าเป็น 40 หรือ สูงกว่า
short_open_tag ต้องเป็น On
disable_function ต้องไม่มี ini_get, ini_set, enable_dl
post_max_size = ?M
upload_max_filesize = ?M
? คือค่าที่ต้องการ หากต้องการโพสต์ข้อความขนาดใหญ่ ๆ
และหากต้องการ upload file ขนาดใหญ่ ตามลำดับ
post_max_size ปัจจุบันเป็น 64M
upload_max_filesize ปัจจุบันเป็น 64M
enable_dl ต้องเป็น On


php extension (php.ini)

curl
openssl
xmlrpc
ช่วยให้การทำงานบนเน็ตเวิร์กดีขึ้น (ไม่จำเป็น)


php extension (php.ini)

iconv
mbstring
tokenizer
ctype
ช่วยในการทำงานกับสตริง (ไม่จำเป็น แต่แนะนำให้เปิด)
default_charset If you can't read "ทดสอบ" set default_charset="utf-8" in php.ini


เซิร์ฟเวอร์ของท่านไม่ผ่านความต้องการของระบบนี้
อาจทำให้การทำงานของระบบไม่สมบูรณ์ กรุณาตรวจสอบใหม่อีกครั้ง